IBM Support

Issues with the IoT Messaging Component in Small/Development deployments of Maximo Application Suite

Troubleshooting


Problem

The Messaging component of the IoT application in the smallest deployment size will appear to the user to not save any of the applied configuration after the messaging components are restarted.

Symptom

The IoT Messaging component will not save any config or messaging data beyond a restart.

Cause

In the smallest deployment size of IoT, there are not enough resources to configure a PersistentVolumeClaim ("PVC") for the IoT Messaging component, which has a very specific minimum requirement for backend storage.  Beacause there is no persistent backend storage configured for the component, all messaging and configuration data is stored in ephemeral storage inside the containers, which is lost during restarts.

Resolving The Problem

There is currently no resolution for this.  The size of the minimal deployment of IoT is only meant for development environments and lacks the resources to allow the required PVC to be configured for the messaging component.  If messaging services are required, one must use a larger deployment size.

Document Location

Worldwide

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Document Information

Modified date:
23 June 2021

UID

ibm16465993