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The Maximo Application Suite user interface is not accessible after initial setup due to missing MongoDB cluster CA certificates

Troubleshooting


Problem

If the MongoDB cluster uses self-signed CA certificates, you must upload the certificates during Maximo Application Suite initial setup. Initial setup documentation incorrectly states that CA certificates upload is optional for MongoDB.

Symptom

The Maximo Application Suite initial setup completes successfully, but the user cannot access the suite user interface because of browser timeout.

Cause

The MongoDB cluster uses self-signed CA certificates, but the required certificates are not uploaded as part of configuring the MongoDB settings in Maximo Application Suite initial setup. 

Environment

A Maximo Application Suite instance that is configured for a MongoDB cluster that uses self-signed CA certificates.

Resolving The Problem

To have the user interface working, you have to include the certificates in the Mongo Configuration. 
From the Overview console in the OpenShift Cluster:
  1. Open the Administration section on the left side menu.
  2. Click Custom Resource Definition.
  3. In the search box type, Mongocfg
  4. Click Instances.
  5. In the search box type, the instance-name that you provided during the Maximo Application Suite installation.
  6. Click the resource found.
    Example: instance_name-mongo-system
  7. Select the YAML tab.
  8. Add the certificates under spec.
    spec:
      certificates:
        - alias: ca
          crt: |
            -----BEGIN CERTIFICATE-----
            ....
            -----END CERTIFICATE-----
        - alias: server
          crt: |
            -----BEGIN CERTIFICATE-----
            ...
            -----END CERTIFICATE-----
      config:
       ....
  9. After that go to Workloads on the left side menu.
  10. Click Pods.
  11. In the search box type, coreapi.
  12. For each pod found, go to Actions and click Delete Pod.
  13. In the search box type, coreidp.
  14. Go to Actions and click Delete Pod.
    Important: pay attention to delete the coreidp pod and not the coreidp-login pod. 
  15. In the search box type, admin-dashboard.
  16. Go to Actions and click Delete Pod.
  17. Go to Custom Resource Definition on the left side menu, under Administration.
  18. In the search box type, Truststore
  19. Click Instances.
  20. In the search box type, the instance-name.
  21. Click the resource found.
    Example: instance_name-truststore
  22. Select the YAML tab.
  23. Under status.truststore, you can see the certificates were included in the truststore.
    Example: instance_name-mongo-system.ca
                       instance_name-mongo-system.server
You must wait for all the pods to be in Ready state. After a few minutes, you will be able to access the user interface.
 

Document Location

Worldwide

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Document Information

Modified date:
23 June 2021

UID

ibm16461907