Troubleshooting
Problem
After restarting machine on which Planning Analytics Workspace is installed accessing Workspace from browser displays "Planning Analytics Workspace is unavailable. Try again in a few minutes.".
Symptom
Running /scripts/paw.ps1 ps on Planning Analytics Workspace machine shows that social container is in "Restarting" state.
Cause
Corrupted paw_couchdb docker volume.
Resolving The Problem
- Run /scripts/backup.ps1 to save all data.
- Run docker rm couchdb social to remove couchdb and social containers.
- Run docker volume rm paw_couchdb to remove couchdb volume (ATTENTION make sure that backup was performed as removing paw_couchdb volume will remove all data stored in that database).
- Run /scripts/paw.ps1 to recreate volumes and all containers.
- Run /scripts/paw.ps1 ps to verify that social container is in "Up" state.
- Run /scripts/restore.ps1 <folder name> script to restore data that was removed from paw_couchdb volume.
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m50000000KzIzAAK","label":"Planning Analytics Workspace"},{"code":"a8m50000000KzKqAAK","label":"Planning Analytics Workspace-\u003EDocker"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]
Product Synonym
Planning Analytics Workspace;Workspace;PAW
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Document Information
Modified date:
10 December 2021
UID
ibm16457919