IBM Support

Unable to Activate the Manage Application within Maximo Application Suite

Troubleshooting


Problem

When activating Manage within Maximo Application Suite, the following error can occur regarding a certificate signed by an unknown authority

Symptom

AIUCO1999E: Internal Server Error: 500 Reason: Internal Server Error HTTP response headers:

HTTPHeaderDict({'Audit-Id': 'd3933e42-c1ab-4941-879a-8aad080b31ee', 'Cache-Control': 'no-cache, private', 'Content-Type': 'application/json', 'X-Kubernetes-Pf-Flowschema-Uid': '0a19d8aa-a252-4fbb-aeb5-6f3b9f316661', 'X-Kubernetes-Pf-Prioritylevel-Uid': '30d251fa-e7a4-433c-ad1f-4cf5e064f475', 'Date': 'Wed, 26 May 2021 17:25:18 GMT', 'Content-Length': '641'}) HTTP response body: b'{"kind":"Status","apiVersion":"v1","metadata":{},

"status":"Failure","message":"Internal error occurred: Failed calling webhook "ibm-mas-manage-operator-service.mas-{INSTANCE_ID}-manage.svc ":Post "https://ibm-mas-manage-operator-service.mas-{INSTANCE_ID}-manage.svc:443/validate?timeout=10s ": x509: certificate signed by unknown authority","reason":"InternalError","details":{"causes":[ {"message":"failed calling webhook \\"ibm-mas-manage-operator-service.mas-{INSTANCE_ID}-manage.svc\\":

Post \\"[https://ibm-mas-manage-operator-service.mas-{INSTANCE_ID}-manage.svc:443/validate?timeout=10s|https://ibm-mas-manage-operator-service.mas-{INSTANCE_ID}-manage.svc/validate?timeout=10s]\\": x509: certificate signed by unknown authority"}]},"code":500}\n' Original traceback: File "/usr/local/lib/python3.7/site-packages/openshift/dynamic/client.py", line 42, in inner resp = func(self, *args, **kwargs) File "/usr/local/lib/python3.7/site-packages/openshift/dynamic/client.py", line 247, in request

Cause

 The ca-injector pod in cert-manager namespace needs to be restarted

Resolving The Problem

Log in to Red Hat OpenShift Environment
Under Workloads > Select Pods
Change Project Name to > cert-manager
In search field type > cainjector
Click the 3 dots to display drop down > Select Delete Pod
Confirm you want to delete the pod > Select Delete
 
The new pod generates
Go back to Maximo Application Suite 
Retry Activation
cainjector

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hAeaAAE","label":"Maximo Application Suite->Manage"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
03 June 2021

UID

ibm16457829