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IBM Security Guardium™ report running in Interactive Mode closes with error: "You do not have privileges to see this report"

Troubleshooting


Problem

You are trying to run a report that you created, but the system presents a chain of error messages:
Unexpected error has occurred. Please Contact your System Administrator.
Followed by:
You do not have privileges to see this Report

Symptom

The error message is displayed when trying to run a report in interactive mode.

Cause

There are two possible causes to this problem.
  1. The log in ID you are using lacks of privileges to view the report (as the error message suggests).
  2. There is an inconsistency between the Report Object configuration displayed at the graphical user interface (GUI) and the Guardium™ internal database. This document focuses on this last scenario. The problem is presented regardless of you running the report with the "admin" user or a user with the "admin" role.

Diagnosing The Problem

1. As a preparation step, you configure the Guardium™ appliance to collect the GUI debug information. You can accomplish the task either by collecting the "App Issues MustGather", known as "User interface", in the "Manage > Maintenance > Support Information Gathering" screen, or use the command "support must_gather app_issues" from the command-line interface (CLI). Check the document "How to collect Application Debugging information to diagnose a Guardium™ application error (manual method)" at the Related URL section of this page to know more.
2. Login to the GUI. Open the report of your interest.
Example:
Suppose that you placed a report in the path "Reports > My Custom Reports". When you open the intended report, you get the error message.
image 10052
As soon as you click the  "Close" button, another message is displayed.
image 10053
3. If you collected the GUI debug information while reproducing the problem, the corresponding debug log file "<YYYY-MM-DD>-debug.log" (where "<YYYY-MM-DD>" represents the date when the debug trace file is generated) might contain a much more accurate error message to complement the diagnosis.
Thread: http-bio-8443-exec-88 - Guard Report Generator: This query is invalid as underlying metadata has changed. Please go to query builder to revalidate it.
As suggested by the error, the report has some internal inconsistencies that conflict in the database.
 

Resolving The Problem

In order to fix this problem, save the report object again in order to fully synchronize its metadata.
1. From the GUI, go to "Reports > Report Configuration Tools > Query-Report Builder". Find the interested report object. Open it with the editor.
2. Click the "Save" button at the bottom of the page.
image 10054
3. The system should confirm the report object was saved successfully.
image 10055
4. Finally, try to run the report again. This time it should run without errors.
image 10056
Note 1. In this example, the report is not returning any data, but the report ran without errors.

Document Location

Worldwide

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Document Information

Modified date:
22 June 2021

UID

ibm16455653