IBM Support

Report emails are stuck in waiting status after adding hive drivers to the environment

Troubleshooting


Problem

Scheduled reports that are sending out emails are stuck in waiting status after adding hive drivers to the drivers folder and restarting the application tier installation.

Symptom

Scheduled reports show as stuck in waiting status in Cognos Administration under current activities.
 

Cause

We have noted some issues with the Cloudera drivers in the past as documented here:

https://www.ibm.com/support/pages/node/6406030 and this was fixed in versions starting from 3.1.0.3.1.0.0-78 of the Apache Hive driver

 The issue here is that WebSphere Liberty application server has a logic to look no further if the Jar file already has JavaMail set up it is using it and it is incorrect.  Using higher releases of the Jar file corrects this issue.

Diagnosing The Problem

SDS trace shows information displayed that indicates the connection to the mail server is no longer working.
MessagingException: javax.mail.NoSuchProviderException: No provider for smtp
CNC-DS-0001 The following Delivery Service general error occurred: No provider for smtpNo provider for smtp
Problem with mail server, will test again in 30 seconds DLS TRACE

Resolving The Problem

Use hive driver version 3.1.3000.7.2.7.0-89 or higher resolved the email server connection.

Document Location

Worldwide

[{"Type":"SW","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m0z0000001jonAAA","label":"Schedules"}],"ARM Case Number":"TS005646788","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.1.5;11.1.6;11.1.7"}]

Document Information

Modified date:
03 November 2021

UID

ibm16454779