IBM Support

Creating a new Automation Document Processing project fails with Unexpected Error

Troubleshooting


Problem

When you create a new automation project for Automation Document Processing, the project creation fails.  The error message shows only Unexpected Error.  The project does get created, but if the user opens it, they get a No Available Databases message.

Cause

If project creation takes too long, the task may timeout before creation is complete.  This timeout flags the database as unavailable but does not correctly attach the database to the project.

Resolving The Problem

For a Production (Enterprise) deployment, creating more project databases resolves the issue.
For a Starter (Demo) deployment, the existing project databases can be reset to show as available.  After you reset the database, the originally created project can be opened. For instructions, see Resetting Automation Document Processing project databases in Starter deployments.
Note:  This procedure is specific for a Starter deployment where an initial project creation failure occurred.  Resetting the database availability does not reset the data itself, nor does it fix any type of corruption in the database.  Resetting the database for a successfully deployed project causes the project to fail.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBYVB","label":"IBM Cloud Pak for Business Automation"},"ARM Category":[{"code":"a8m3p000000hAKPAA2","label":"Operate-\u003EADP Install\\Upgrade\\Setup"}],"ARM Case Number":"TS005548256","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
08 February 2023

UID

ibm16450891