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Upgrade failures when trying to Upgrade IBM Security SOAR

Troubleshooting


Problem

When trying to run the upgrade for IBM Security SOAR

Symptom

The users listed in the sudoers group did not have expired passwords, trying the upgrade using the root user also failed with the same error:
$ resSystemBackup
check if there is incomplete Transactions....
sudo: Password expired, contact your system administrator

Cause

 After copying the files to the server, the admin users will also need to have executable permission on the run file.

Environment

IBM Security SOAR on Red Hat Linux 7.4

Diagnosing The Problem

Confirm resadmin is in the sudoers group:
cat /etc/sudoers
Check to see if the resadmin users password has expired:
chage -l resadmin
lCheck the file permissions on the run files:
ls -l /home/resadmin/*.run

Resolving The Problem

Run the command to allow execute permissions on the upgrade files:
$ sudo chmod +x /home/resadmin/40.2.73.run

Document Location

Worldwide

[{"Type":"SW","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSIP9Q","label":"IBM Security SOAR"},"ARM Category":[{"code":"a8m0z0000001h0WAAQ","label":"Installation \/ Upgrade->Operating System"}],"ARM Case Number":"TS005540202","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
30 April 2021

UID

ibm16448980