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IBM Cognos Analytics Mobile CA11.1.7 FP2 configuration fails when using a Load Balancer in your environment.

Troubleshooting


Problem

The Mobile configuration script needs to verify that the Cognos Analytics Application Tier server is running.  With a Load Balancer configured in the Dispatcher's Gateway URI, the verify message can be directed to a different Dispatcher and not the one being configured, causing the process to fail.  These steps will separate the Dispatcher being configured.

Symptom

After running the --task configure or --task verify you are NOT asked for your Credentials or you see CA health check: false.

Cause

The Load Balancer is redirecting the script to a different Dispatcher causing it to not react properly.

Resolving The Problem

If you cannot stop all Dispatchers in a Cognos Analytics system to configure them one by one, you can use these steps to separate the Dispatcher to be configured.  If you can stop all the Dispatchers, follow the Documentation for setting up Mobile Fix Pack 2, then shut it down once that Verify task is complete.
Before setting up the Mobile service, change the Application Tier's Gateway to point to the 'Dispatcher URI for external applications', save the configuration and restart the software.  This is to allow the change to be written to the the ..\configuration\dispatcher.properties file.
Steps to Change Application Tier Dispatcher's Gateway URI to the 'Dispatcher URI for external applications':
1) Launch Cognos Configuration
2) Navigate to Local Configuration > Environment
3) Copy and save the 'Gateway URI' to be able to restore it later
4) Copy the 'Dispatcher URI for external applications' string into the 'Gateway URI'
5) Select Save Icon or File > Save
6) Restart the Dispatcher
7) Close configuration tool
Install and configure the Mobile CA11.1.7 Fix Pack 2 as per the Documentation.
Steps to revert the changes made after you verify the Mobile installation:

1) Launch Cognos Configuration
2) Navigate to Local Configuration > Environment
3) Restore 'Gateway URI' previously saved
4) Select Save Icon or File > Save
5) Restart the Dispatcher
6) Close the configuration tool
Should the script fail to request the Credentials of a Cognos Analytics System Administrator, check the log file in:
<Mobile installation location>\mobile-config\mob-config.log file.

Document Location

Worldwide

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Document Information

Modified date:
28 April 2021

UID

ibm16447165