IBM Support

IBM Maximo Application Suite - Installation fails with error: requested access to the resource is denied

Troubleshooting


Problem

Maximo Application Suite stopped and showing error on app-suite operator:
> oc describe pod appsuite-operator-xxxxxx-xxx
..........
Events:
  Type     Reason          Age                  From               Message
  ----     ------          ----                 ----               -------
  Normal   Scheduled       169m                 default-scheduler  Successfully assigned mas-cog-dev-mas-core/appsuite-operator-xxxxxx-xxx to x.x.x.x
  Normal   AddedInterface  169m                 multus             Add eth0 [x.x.x.x/32]
  Warning  Failed          167m (x4 over 169m)  kubelet            Failed to pull image "cp.icr.io/cp/mas/appsuite-operator:8.3.0": rpc error: code = Unknown desc = Error reading manifest 8.3.0 in cp.icr.io/cp/mas/appsuite-operator: errors:
denied: requested access to the resource is denied
unauthorized: authentication required
  Warning  Failed   167m (x4 over 169m)     kubelet  Error: ErrImagePull
  Normal   BackOff  29m (x611 over 169m)    kubelet  Back-off pulling image "cp.icr.io/cp/mas/appsuite-operator:8.3.0"
  Warning  Failed   8m59s (x698 over 169m)  kubelet  Error: ImagePullBackOff
  Normal   Pulling  4m1s (x37 over 169m)    kubelet  Pulling image "cp.icr.io/cp/mas/appsuite-operator:8.3.0"

Symptom

MAS images cannot be pulled from repositories and installation end in with error:
Warning  Failed          167m (x4 over 169m)  kubelet            Failed to pull image "cp.icr.io/cp/mas/appsuite-operator:8.3.0": rpc error: code = Unknown desc = Error reading manifest 8.3.0 in cp.icr.io/cp/mas/appsuite-operator: errors:
denied: requested access to the resource is denied
unauthorized: authentication required
  Warning  Failed   167m (x4 over 169m)     kubelet  Error: ErrImagePull

Cause

Symptoms indicate a problem with the access to MAS images repositories or the Entitlement key was wrongly introduced and there is a typo in it.

Resolving The Problem

If the problem is related to access, customers can check if this is the case by accessing the IBM Container library at :

https://myibm.ibm.com/products-services/containerlibrary

then from the left menu choose "View library" and under "Container software library" check if Maximo Application Suite shows up in the list. (or "all" appears under an IBM SOFTWARE ACCESS X YEAR).
If "View library" option is inactive it means that you don't have any entitle products for your account. If you consider that there is mistake, please contact your IBM account manager or sales representative.
If the problem is caused by wrongly entered the entitlement key the you need to edit it in ibm-entitlement secret from mas-core namespace/project.

Document Location

Worldwide

[{"Type":"SW","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000GoLBAA0","label":"Maximo Application Suite->Installation"}],"ARM Case Number":"TS005468782","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
21 April 2021

UID

ibm16445785