IBM Support

Maximo Application Suite - Installation fails with error java: command not found

Troubleshooting


Problem

After running the installation script, the installation process might fail with
./install.sh: line 374: java: command not found
Installation aborted because license terms were not accepted
E.g.
$ oc login --token=sha256~XXXXXXXXX-A --server=https://server
$ export ENTITLEMENT_KEY=XXXXXXXXXXXXX
$ ./install.sh -i mas-instance --domain server.hostname
======================================================================
Maximo Application Suite Installer 8.3.0
======================================================================
- Instance Name: mas-instance
- Log Directory: logs
- IBM Customer Number: > xxxxxx
- Customer Name: > Customer 
- Country Code: > XXX
- Domain: server.hostname
./install.sh: line 374: java: command not found

Installation aborted because license terms were not accepted

Symptom

Installation aborted with the following message:
./install.sh: line 374: java: command not found
Installation aborted because license terms were not accepted

Cause

The reason of the failure is that java is not installed on the system.

Resolving The Problem

Check if java-jdk is installed on the machine from where you launched the install script, if not please use your system's package manager to install your company's accepted java-jdk package.

Document Location

Worldwide

[{"Type":"SW","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000GoLBAA0","label":"Maximo Application Suite->Installation"}],"ARM Case Number":"TS005424299","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
16 April 2021

UID

ibm16444063