Troubleshooting
Problem
When you try to deploy Maximo Visual Inspection application from Maximo Application Suite dashboard on OpenShift hosted in IBM Cloud then you can get a message saying: This application is being deployed (Last updated: xxxxx, xxxxxxx) and no progress towards deployment can be done.
Symptom
Inspecting the MVI pods it can be seen that task-pvc-mvi-data-pvc pod is in pending state:
[root@ibmserver ~]# oc get pods
NAME READY STATUS RESTARTS AGE
mas-task-pvc-mvi-data-pvc 0/1 Pending 0 3d
mas-trackdeploy-deploy-pending-xxxxx 0/2 Completed 0 3d
visualinspection-operator-xxxxxxxxxx-xxxxx 1/1 Running 0 3d
Cause
The chosen storage class is a problem. According to the IBM Cloud Docs for Containers Block Storage:
> Block storage comes with a ReadWriteOnce access mode. You can mount it to only one pod on one worker node in the cluster at a time.
Diagnosing The Problem
Inspecting the PVCs will show that ibmc-block-gold storage volume is used:
[root@ibmserver ~]# oc get pvc -A
NAMESPACE NAME STATUS VOLUME CAPACITY ACCESS MODES STORAGECLASS AGE
........
mas-masibm-visualinspection mvi-data-pvc Pending ibmc-block-gold 4d2h
........
Resolving The Problem
In such cases we suggest to use ibmc-file-gold for the PVC configuration.
To solve the problem, delete the current deployment of the application and redeploy specifying ibmc-file-gold as the storage class.
Document Location
Worldwide
[{"Type":"SW","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hAeUAAU","label":"Maximo Application Suite->Visual Inspection"}],"ARM Case Number":"TS005391741","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.3.0"}]
Was this topic helpful?
Document Information
Modified date:
12 April 2021
UID
ibm16442091