Troubleshooting
Problem
When Cognos Analytics is hosted on AWS, and SSO is enabled.
Browser prompts from credentials on every single transaction on Cognos portal.
Symptom
Authentication prompt on each click/transaction.
Cause
AWS load balancer does not work properly when set up with application mode.
Resolving The Problem
Switch the AWS load-balancer from Application Mode to TCP Mode.
Reference : https://stackoverflow.com/questions/22942777/windows-authentication-behind-aws-elastic-load-balancer-elb-not-working
NOTE:
IBM Customer Support can not assist in any changes to be made on AWS. We can ONLY recommend the change. The change must be done by AWS admin.
Before making any change, please consult your security team as any changes on load-balancer may affect other operations on Cognos Analytics.
Document Location
Worldwide
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Document Information
Modified date:
07 April 2021
UID
ibm16441093