Troubleshooting
Problem
There is a rule in Control Center monitoring for CCFA004I with linked rule looking for CCFA003I.
Control Center is issuing an alert from this rule stating that the CD File Agent is down.
Occurs on random File Agents not always the same CDFA.
Symptom
Getting false alerts that CD File Agents are down.
Cause
Database processing is extremely slow some time taking over two minutes to process in coming traps.
Diagnosing The Problem
Edit EngineLogger.xml and turn on debugging for FileAgentService changing level from INFO to DEBUG,
Review the FileAgentService logs and look for;
WARN FileAgentService - FileAgentService took an inordinate amount of time to begin processing of trap
Resolving The Problem
Increase the fileAgentHeartBeatInterval value in FileAgentService.xml from 90 to 300.
It dictates the number of seconds ICC will wait for a new trap from a CD File Agent before generating a File Agent is Down event.
There are times it is taking 2+ minutes though just for ICC to process some traps.
This particular parameter will require all EPs to be stopped and restarted for the change to take effect.
Document Location
Worldwide
[{"Type":"SW","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9GLA","label":"IBM Control Center"},"ARM Category":[{"code":"a8m0z000000cwVsAAI","label":"CDFA"}],"ARM Case Number":"TS005028614","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.1.3;and future releases"}]
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Document Information
Modified date:
06 April 2021
UID
ibm16440535