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Control Center web page on 58082 and 58083 is unavailable with a 503 error

Troubleshooting


Problem

New Install of Control Center 6.2.0 using Microsoft 2019 Database
The web portal is unavailable on port 58082 (non-secure) and 58083 (secure). Seeing an HTTP 503 ERROR - Service unavailable.
There is something called hibernate.instance as an error in the ccweb_<date>.log that seems suspicious. SQL Server 2019 is case-sensitive, so if CCM is trying to reference something called 'hibernate.sequence' instead of HIBERNATE.SEQUENCE then that explains the error. This error seems to coincide with an attempted login.

Symptom

Can not reach the Web Console.

Cause

The Microsoft Database was created with the wrong collation setting.
The collation required is SQL_Latin1_GenealCP1_CI_AS which is not case sensitive

Environment

Microsoft Database Server 2019

Diagnosing The Problem

Engine Logs show INFO JDBCService - Database is case sensitive
ccweb logs show SQL Error: 208, SQLState: S0002 Invalid object name 'hibernate_sequence'.

 

Resolving The Problem

Recreate the Database with the correct Collation Setting

Document Location

Worldwide

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Document Information

Modified date:
26 March 2021

UID

ibm16436869