IBM Support

IBM Secure Gateway unable to connect

Troubleshooting


Problem

IBM Secure Gateway configuration file, securegw_service.config, has 7 Gateway IDs and 7 security tokens listed. All of these are valid but the Secure Gateway for 5 of the Gateway IDs will not start up successfully.

Symptom

The Secure Gateway gateway ID was either not recognized or requires a security token to connect, error was: 401
Process exiting without errors due to user or server request

Cause

The Secure Gateway service is very sensitive to extra spaces, carriage returns (CR) and line feeds (LF). In this particular case, the security tokens were separated by CR/LF, so they were not being read correctly. The tokens should only be separated by '--'. 
Note these are not real tokens and have been replaced for security reasons and demonstration purposes
#Enter the security tokens separated by --
SECTOKEN=token1--token2--
token3--
token4--
token5--
token6--
token7

Environment

Planning Analytics on Cloud
IBM Secure Gateway

Resolving The Problem

To resolve the issue, remove any extra whitespaces and CR/LF:
#Enter the security tokens separated by --
SECTOKEN=token1--token2--token3--token4--token5--token6--token7

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m0z000000GmwdAAC","label":"Troubleshooting->Secure Gateway"}],"ARM Case Number":"TS005276149","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
23 March 2021

UID

ibm16435219