IBM Support

Intermittent Connection Errors in PA Workspace or PA for Excel when MaximumPorts for user is set too low

Troubleshooting


Problem

Users in PA for Excel or PA Workspace may experience intermittent connection related errors if their connections to the TM1 Server have been limited via the MaximumPorts setting.

Symptom

Possible errors:
  • "Unable to Fetch Data"
  • "Unable to compose your request"
  • "httpStatusCode" 401,"Authenticate" "

Cause

Planning Analytics Workspace and Planning Analytics for Excel use asynchronous connections to the TM1 Server to allow for greater performance.  Older PA Client tools would not use such asynchronous connections and would continue to use the same connection already open to the TM1 Server.

Resolving The Problem

Customers using Planning Analytics Workspace or Planning Analytics for Excel must set the MaximumPorts setting to 0, which will allow unlimited connections. 

See the following link for details on setting MaximumPorts: 
https://www.ibm.com/support/knowledgecenter/SSD29G_2.0.0/com.ibm.swg.ba.cognos.tm1_op.2.0.0.doc/c_clientproperties_n60571.html

Document Location

Worldwide

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Document Information

Modified date:
02 March 2021

UID

ibm16420419