IBM Support

Unable to successfully SFTP to IBM Planning Analytics Cloud

Troubleshooting


Problem

When trying to establish a connection to the SFTP server on IBM Planning Analytics Cloud, a PuTTY or WinSCP session fails. The same connection from Filezilla works without issue.

Symptom

Error:
From UI - PuTTY Fatal Error
                   Server refused to start a shell/command
                   Server refused to allocate pty
From Command Line - Server's host key did not match the signature supplied
                                           Fatal: Server's host key did not match the signature supplied

Cause

The older client tools do not have the necessary/proper strength ciphers to connect to the new SFTP server.

Environment

Planning Analytics on Cloud
SFTP server hosted on Cloud

Diagnosing The Problem

Confirmed that the SFTP server's fingerprint is what is being stored on the client server
  • Removed/renamed the known hosts file or entry in the registry on client server then retried the same connection.  Trusted the fingerprint from the host server when prompted but received the same error.
Tried a different SFTP tool on the same server
  • Filezilla connected without error
  • Tectia SSH client connected without error
Tried the same connection but on a different server
  • PuTTY connection successful
PuTTY version working:  SSH-2.0-PuTTY_Release_0.74
PuTTY version not working:  SSH-2.0-PuTTY_Release_0.63

Resolving The Problem

To resolve the connection problem, PuTTY was upgraded to SSH-2.0-PuTTY_Release_0.74. 
PuTTY 0.63 was released around 2014 while the SFTP server on the IBM Planning Analytics Cloud is newer. Likely the cipher suits between the client tool and the SFTP server did not match causing a connection error.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m0z000000blsYAAQ","label":"Troubleshooting"}],"ARM Case Number":"TS005065297","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
23 February 2021

UID

ibm16416753