IBM Support

No TM1 Server visible in the databases list in Workspace when creating or updating a book

Troubleshooting


Problem

In Planning Analytics Workspace,
in "Reports and Analysis"
"Create" --> "Book" menu
"Databases" button
The "Data" frame is empty/blank ; there is no TM1 server displayed/listed, no TM1 Server is visible/available.

Cause

1) TM1 Servers are not started or TM1 Admin Server is not accessible
2) The URI used by Workspace to reach TM1 Admin Server is incorrect
3) TM1 Admin Server is configured with custom SSL/TLS and Workspace does not trust the root certificate
4) The host name has an underscore in its name. These messages are found in the logs:
-In prism-proxy log:
HTTP error 500 during "GET http://prism-proxy:9090/prism/harmony/tm1serverexplorer/api/v1/Servers?viewmode=architect"
-In pa-gateway log:
"GET /prism/harmony/tm1serverexplorer/api/v1/Servers?viewmode=architect HTTP/1.1" 500 91 "http://bad_machine_name_with_underscore/?perspective=dashboard&id=dashboard_9a3ac190-3efc-4ec7-b74c-1b3dd830222f"
-In prism-platform log:
[2/17/21 10:25:11:469 CET] 0000007e com.ibm.ba.pm.harmony.common.endpoint.BaseEndpoint  E Error
java.lang.reflect.UndeclaredThrowableException
 at com.sun.proxy.$Proxy136.getBaseUri(Unknown Source)
 at com.ibm.ba.pm.harmony.common.tm1.utils.ResponseUtils.getBaseHREF(ResponseUtils.java:144)
 at com.ibm.ba.pm.harmony.tm1serverexplorer.endpoints.TM1ServerExplorerBaseEndPoint.createRequestInfo(TM1ServerExplorerBaseEndPoint.java:109)
 at com.ibm.ba.pm.harmony.tm1serverexplorer.endpoints.servers.ServersEndPoint.getServers(ServersEndPoint.java:32)
...
Caused by: java.lang.reflect.InvocationTargetException
...
Caused by: java.lang.IllegalStateException: java.net.URISyntaxException: Illegal character in hostname at index 9: http://bad_machine_name_with_underscore:80/
...
Caused by: java.net.URISyntaxException: Illegal character in hostname at index 9: http://bad_machine_name_with_underscore:80/
 at java.net.URI$Parser.fail(URI.java:2858)
 at java.net.URI$Parser.parseHostname(URI.java:3397)
...

Resolving The Problem

1) Verify TM1 Servers are started and accessible from Architect and TM1 Web. If possible, for the test, use an Architect that is installed on the same host as Workspace.
2) Open the AdminTool (<PAW_PATH>/scripts/admintool.ps1) and click the "Validate" button to verify that Workspace can reach the TM1 Admin Server through the "TM1 Admin Server URI" that has been defined. Also verify there is no firewall blocking TM1 Admin Server HTTPS port 5898 or any PortNumber or HTTPPortNumber used by any TM1 Server (check these parameters in tm1s.cfg).
3) If TM1 Data Tier (TM1 Admin Server and TM1 Servers) is configured with custom SSL/TLS, and the root Certification Authority (root CA) is proprietary too (CA not recognized outside the Company), or the server certificate is a self-signed certificate, then  import the root CA certificate or the self-signed certificate into Workspace by using process_certs.ps1 script, as described in official documentation:
https://www.ibm.com/support/knowledgecenter/en/SSD29G_2.0.0/com.ibm.swg.ba.cognos.tm1_inst.2.0.0.doc/t_paw_enable_ssl_with_servers.html
This may require to run "/scripts/paw.ps1" to regenerate containers.
4) Correct the name of the machine hosting Workspace so that it does not contain any underscore '_' character:  This is not supported.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m50000000KzIzAAK","label":"Planning Analytics Workspace"},{"code":"a8m0z000000blfjAAA","label":"Troubleshooting"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]

Product Synonym

PAW

Document Information

Modified date:
18 February 2021

UID

ibm16416011