IBM Support

Unable to log in to Planning Analytics for Excel - System.Runtime.Serialization.SerializationException

Troubleshooting


Problem

Users are unable to log in to Planning Analytics for Excel

Symptom

image 8417

System.Runtime.Serialization.SerializationException: Type 'Cognos.Office.Tm1.Connections.Tm1WebException' in Assembly 'TM1.Common, Version=11.0.52.9, Culture=neutral, PublicKeyToken=d6e6d7d808b7e5b7' is not marked as serializable.
Server stack trace: 
   at System.Runtime.Serialization.Formatters.Binary.WriteObjectInfo.InitSerialize(Object obj, ISurrogateSelector surrogateSelector, StreamingContext context, SerObjectInfoInit serObjectInfoInit, IFormatterConverter converter, ObjectWriter objectWriter, SerializationBinder binder)
   at System.Runtime.Serialization.Formatters.Binary.WriteObjectInfo.Serialize(Object obj, ISurrogateSelector surrogateSelector, StreamingContext context, SerObjectInfoInit serObjectInfoInit, IFormatterConverter converter, ObjectWriter objectWriter, SerializationBinder binder)
   at System.Runtime.Serialization.Formatters.Binary.ObjectWriter.Serialize(Object graph, Header[] inHeaders, __BinaryWriter serWriter, Boolean fCheck)
   at System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Serialize(Stream serializationStream, Object graph, Header[] headers, Boolean fCheck)
   at System.Runtime.Remoting.Channels.CrossAppDomainSerializer.SerializeMessageParts(ArrayList argsToSerialize)
   at System.Runtime.Remoting.Messaging.SmuggledMethodReturnMessage..ctor(IMethodReturnMessage mrm)
   at System.Runtime.Remoting.Messaging.SmuggledMethodReturnMessage.SmuggleIfPossible(IMessage msg)
   at System.Runtime.Remoting.Channels.CrossAppDomainSink.DoDispatch(Byte[] reqStmBuff, SmuggledMethodCallMessage smuggledMcm, SmuggledMethodReturnMessage& smuggledMrm)
   at System.Runtime.Remoting.Channels.CrossAppDomainSink.DoTransitionDispatchCallback(Object[] args)

Cause

-This specific error occurs when Planning Analytics Workspace cannot communicate with the TM1 Server
-Even though parts of Workspace may communicate correctly, this error is caused when the Workspace tm1proxy service cannot connect
-In this scenario, the TM1 Server is using a custom SSL certificate
-Although the correct certificates were in the /Workspace/config/certs/ folder, the file permissions were missing read on everyone group

Diagnosing The Problem

On the Workspace Install machine, type: docker logs tm1proxy
 
If you are encountering this same problem, you will see a message similar to: 
  http: proxy error: x509: certificate signed by unknown authority

Resolving The Problem

To resolve the problem allow read permission on the certificate files for the everyone group and restart Planning Analytics Workspace

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m50000000KzIzAAK","label":"Planning Analytics Workspace"},{"code":"a8m50000000KzJ4AAK","label":"Planning Analytics for Microsoft Excel"}],"ARM Case Number":"TS004659720","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
17 February 2021

UID

ibm16415919