IBM Support

CM-CFG-5139 Duplicate namespace id '<Namespace ID>'. Namespace with the same id but different name already exists.

Troubleshooting


Problem

Error specified below is encountered on the login screen of Cognos Analytics when a user is trying to Sign In:
AAA-AUT-0013, user is already authenticated in all available name spaces.
Which is followed by the error in the logs when trying to start the Cognos Server or the Content Manager for the same Server:
CM-CFG-5139 Duplicate namespace id '<Namespace ID>'. Namespace with the same id but different name already exists.

Cause

This issue happens when the name of an existing namespace which is registered in Content Store is different than what it is set to in the cognos configuration.

Environment

Cognos Analytics 11.0.X,
Cognos 11.1.X

Resolving The Problem

To resolve this issue, all we need to do is find out the namespace name that is currently associated to the ID, then make sure we use that name in the Cognos Configuration.
 
This can be done by running a couple of SQL queries against your content store database.

***NOTE: Make sure that Cognos is stopped before doing this, and that you have a database backup.
 
1) The first query you will run is:
 
select * from CMOBJPROPS1 where OBJID like '<Namespace ID>'
This query will return a specific CMID value.
2) You will then run another query to find the namespace name associated with that ID:
select * from CMOBJNAMES where CMID=<id returned from the first query>

Example:
select * from CMOBJNAMES where CMID=144
Once you find the name of the namespace, simply update the name in your Cognos Configuration to match what is already in your content store. After this, the duplicate namespace error should go away.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6OAAS","label":"Installation and Configuration->Authentication"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
07 February 2021

UID

ibm16413051