IBM Support

Can not deploy a new Application on App Host, the App host server can not be selected

Troubleshooting


Problem

Can not deploy a new Application on IBM SOAR App Host, because the App Host server can not be selected. 

Symptom

When installing a new application from the SOAR Apps tab, when you try to deploy the application, the drop down list for the App Host sever is blank.
You will be unable to deploy the application until the version of App Host has been updated to the latest version or the version compatible with the version of Resilient SOAR that you are running.

Cause

This issue is fixed by upgrading to the latest version of App Host.
If the App Host has unknown version it will be unable to  pair the application with the App Host. When upgrading to version v39+ of Resilient SOAR you need to also upgrade the version of App Host 1.3, which is required for apps using the secrets capability.

Environment

Customer was running Resilient SOAR version 39.1 and using App Host 1.2.

Resolving The Problem

Upgrading to App Host 1.3 allowed the server list to be populated. A mismatch between the features available for the App Host server and the version of the Resilient server caused the inability for Resilient SOAR to see the AppHost server.

Related Information

Document Location

Worldwide

[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSIP9Q","label":"IBM Security SOAR"},"ARM Category":[{"code":"a8m0z0000001jTpAAI","label":"Integrations->AppHost"}],"ARM Case Number":"TS004898523","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
19 April 2021

UID

ibm16409610