IBM Support

Unable to connect Apache Hive using Kerberos authentication when drivers folder includes Amazon Redshift or Google BigQuery JDBC drivers

Troubleshooting


Problem

A connection to a data source will required the Java run time environment (JRE) to load a JDBC driver. The JRE will search for driver classes in the  <cognos_installation>/drivers directory.

When a  connection to Apache Hive using Kerberos authentication is attempted, it fails due to conflicts in Java classes used by Apache, Google and Amazon.

For example, testing a connection from the Cognos Administration user interface throws an exception error.
XQE-GEN-0002 An unexpected exception occurred: org.apache.commons.configuration2.Configuration

 

Symptom

Connections attempted by the Dynamic Query engine throw exceptions.

Cause


The drivers folder in Cognos Analytics includes a copy of the Apache Hive JDBC driver and one of Google BigQuery or Amazon Redshift JDBC driver.

Apache Hive JDBC driver version 3.1.0.3.1.5.0-152 or higher
  • hive-jdbc-3.1.0.3.1.5.0-152-standalone.jar
  • hadoop-common-3.1.1.3.1.5.0-152.jar
  • hadoop-auth-3.1.1.3.1.5.0-152.jar

Google Bigquery JDBC driver version 1.2.4.1007

Amazon Redshift JDBC driver version 1.2.50.1077
 

Resolving The Problem


In order to avoid this error, you must remove both Google BigQuery and Amazon Redshift JDBC drivers from Cognos drivers folder.
 

Document Location

Worldwide

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Document Information

Modified date:
11 March 2021

UID

ibm16409186