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The CD File Agents are not being monitored by Control Center

Troubleshooting


Problem

Connect Direct File Agent Traps are not getting monitored, even the SNMP port is not listening on the Control Center Controlling Event Processor.

Symptom

Previously monitored CD File Agents are not being monitored. SNMP port does not show listening.

Cause

There are entries in the CC_SERVER_COMPONENT table with a SERVER_ID value that does not reference a server in CC_SERVER, and that is causing the FileAgentService to error out while initializing, and because of that, it never starts listening for traps.

Diagnosing The Problem

CCM Engine log shows [ControllerMonitor] INFO  FileAgentService - Got data needed to initialize file agent trackers added

But never saw the message that started with “Completed initialization of file agent trackers.

see the following error;

[ControllerMonitor] ERROR ServerUtil - Exception in getInfo() for server 2239 - null

java.lang.NullPointerException: null

Resolving The Problem

Must remove all entries from CC_SERVER_COMPONENT that reference a server that does not exist.  And this needs to be done while all EPs have been stopped.

If that can be done precisely, i.e. just removing only the rows in CC_SERVER_COMPONENT that have a SERVER_ID value that does not exist in CC_SERVER, as long as those rows in CC_SERVER that we don’t delete don’t have LOGICALLY_DELETED = 1 since that also means they’ve been deleted. 

Document Location

Worldwide

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Document Information

Modified date:
26 January 2021

UID

ibm16408684