Troubleshooting
Problem
Quick or Universal Reports Displaying Blank Values in TM1Web:
Symptom
- Values are visible using Planning Analytics for Excel (PAfE) without any issues
- Values are not visible in TM1Web (or Planning Analytics Workspace)
Cause
-
The issue is likely caused by the following:
- TM1Web is configured to use a port different than 9510
- TM1Web is configured to use custom certificates
- An SSL secured load balancer or proxy is used with TM1Web
Diagnosing The Problem
- Review the \tm1web\webapps\tm1web\WEB-INF\logs\tm1web.log file for errors
Resolving The Problem
- Ensure the EvaluationServiceUrl in tm1web_config.xml reflects the correct port and/or address:
- <add key="EvaluationServiceUrl" value="http://hostname:port" />
-
If TM1Web is configured to use custom certificates, or An SSL secured load balancer or proxy is used with TM1Web:
-
The certificates securing TM1Web must be imported into the tm1store:
-
Copy the Root and Intermediate certificate files from the Load Balancer to the \tm1web\bin64\ssl\ directory
-
Open Command Prompt, and navigate to <installdir>\tm1web\jre\bin\
-
Type: keytool.exe -import -trustcacerts -file "..\..\bin64\ssl\ca.cert.pem" -keystore "..\..\bin64\ssl\tm1store" -alias ca -storepass applix
-
Type: keytool.exe -import -trustcacerts -file "..\..\bin64\ssl\intermediate.cert.pem" -keystore "..\..\bin64\ssl\tm1store" -alias intca -storepass applix
-
** Update the commands to reflect the name of the Root and Intermediate certificates and provide a relevant alias for the certificates
-
-
Document Location
Worldwide
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Document Information
Modified date:
26 June 2024
UID
ibm16403423