IBM Support

Consumer is not getting any inbound records, please check that DB is running and sending audit records

Troubleshooting


Problem

Using a Cloud DB Service Account, you get the following error when connecting to our Cloud database.
The error seen in the Guardium collector UI under
Cloud DB Service Account -> Provider: <Service Provider> -> Event Hubs
"Consumer is not getting any inbound records, please check that DB is running and sending audit records."

Cause

This will typically occur if the datastream has a stoppage for some time, and the status changes to 'Warning'

Environment

Amazon AWS and/or Microsoft Azure

Diagnosing The Problem

If there is continuous traffic after a stoppage has been recovered

Resolving The Problem

After a datstream status has changed to a 'Warning' state, the only way to change the status back to 'Working' is to disable and enable the stream again. 
To disable and enable the stream, run the following CLI command on the collector:
restart datastream
If this does not resolve the issue, please create a case with IBM Security Support

Document Location

Worldwide

[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"ARM Category":[{"code":"a8m0z000000Gp0cAAC","label":"CLOUD"}],"ARM Case Number":"","Platform":[{"code":"PF004","label":"Appliance"}],"Version":"11.0.0;and future releases"}]

Document Information

Modified date:
22 December 2020

UID

ibm16391836