IBM Support

Users with Consumer role can't access Dashboard even with full permissions in IBM Cognos Analytics

Troubleshooting


Problem

Users which belong to Consumer roles can't access dashboards at all.
Upon giving full permissions on the given dashboards, users were able to open them but couldn't see the content in them. It comes out blank and sometimes throw some errors depending upon what permissions the user has

Symptom

  • Users were having "run" permissions on Dashboards and were able to open dashboards but no content was getting displayed.
  • Users were having 'Read" permissions on Packages that were in use

Cause

The permissions were required on the source directories (Folders) as well.
As consumers didn't have access to team content and so its folders were still inaccessible, due to which users were not able to see any data in the dashboards

Resolving The Problem

As soon as the permissions on the folders were given where packages and datasets were, user was able to see content in dashboards.
For dashboards to work, users need to have following permissions:
  • Run Permission on Dashboard
  • Read permission on Packages/ data module / data set
  • Read permission on folders where we store packages and other sources
Note: In case Admins don't want users to see the folders, they can hide the folders. Hidden folders would still have permissions but would be hidden to user or group or role

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m0z0000001jleAAA","label":"Dashboards"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
28 December 2020

UID

ibm16391588