IBM Support

Unable to Create Quick Report in Planning Analytics for Excel - "Microsoft is waiting for another application to complete an OLE action"

Troubleshooting


Problem

In Planning Analytics for Excel, no users can create a quick report.  The following error is returned:
"Microsoft is waiting for another application to complete an OLE action"

Symptom

After the first error is closed, another error appears:
System.Runtime.InteropServices.COMException (0x80004005): Unspecified error (Exception from HRESULT: 0x80004005 (E_FAIL)) at System.Threading.Monitor.ObjWait(Boolean exitContext, Int32 millisecondsTimeout, Object obj) at System.Threading.ManualResetEventSlim.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken) at System.Threading.Tasks.Task.WaitAllBlockingCore(List`1 tasks, Int32 millisecondsTimeout, CancellationToken cancellationToken) at System.Threading.Tasks.Task.WaitAll(Task[] tasks, Int32 millisecondsTimeout, CancellationToken cancellationToken) at Cognos.Office.Reporting.DataSource.Query.CDLAxisBase..ctor(AxisType axisType, IMetadata axis) at Cognos.Office.Reporting.DataSource.Query.CDLAnalysis..ctor(IMetadata view) at Cognos.Office.Tm1.Mdx.MdxCompiler.CreateAnalysis(IMetadata view) at Cognos.Office.Reporting.Mapping.MetadataContextMenu.DropAnalysis(SheetCoordinate sc) at Cognos.Office.Reporting.Exploration.Toolbar.View.ToolbarEventHandler.Event(Object sender, EventArgs e)

Cause

TM1 Web Tier not running correctly

Resolving The Problem

01) Stop the IBM Cognos TM1 service
02) Remove the contents of the following directory: \tm1_64\wlp\usr\servers\tm1\workarea\
        *This results in an empty workarea folder
        **These are application server related files that may become corrupt if the TM1 Web Tier services are not stopped gracefully
03) Start the IBM Cognos TM1 service

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m50000000KzIaAAK","label":"Installation and Configuration"}],"ARM Case Number":"TS004681765","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]

Document Information

Modified date:
16 December 2020

UID

ibm16383080