Troubleshooting
Problem
高可用性 ( HA ) ペアは、patches.log 内の次のメッセージでソフトウェア更新を適用できません:
この技術情報で説明されている事象は、APAR IJ12252 で正式に報告されています。
[ERROR] Copied patch file to standby host, but MD5 sums do not match.
( [エラー] パッチ・ファイルをスタンバイ・ホストにコピーしましたが、MD5 のチェックサムが一致しません。)この技術情報で説明されている事象は、APAR IJ12252 で正式に報告されています。
Symptom
/var/log/setup-<QRadar_version>/patches.log 内で本事象に類似したメッセージがないか確認してください:
Copying file /storetmp/732_QRadar_interimfix-7.3.2.20190522204210-IF02-20190710135412.sfs to host /storetmp:/storetmp/732_QRadar_interimfix-7.3.2.20190522204210-IF02-20190710135412.sfs
cp: cannot create regular file 'root@/storetmp:/storetmp/732_QRadar_interimfix-7.3.2.20190522204210-IF02-20190710135412.sfs/732_QRadar_interimfix-7.3.2.20190522204210-IF02-20190710135412.sfs': No such file or directory
[ERROR] Couldn't copy patch file FILE to host /storetmp.
[ERROR] Copied patch file to standby host, but MD5 sums do not match.
[ERROR](a-i-has-testmode) HOSTNAME-secondary : patch test failed.
[ERROR](a-i-has-testmode) Patching can not continue
Patch Report for IP-ADDRESS, appliance type: 1828
HOSTNAME-primary : patch test succeeded.
Copied patch file to standby host, but MD5 sums do not match.
Cause
/media/updates/ からファイルをアンマウントする前に SFS ファイルまたは ISO ファイルがディスクから削除されると、このエラー・メッセージが生成されます。 unmount コマンドを入力せずにソフトウェアを削除すると、アプライアンス上でマウント・ポイントがアクティブになり、将来的にソフトウェア更新のエラーが発生する原因となります。
Diagnosing The Problem
- SSHを使用し、更新に失敗した QRadar 高可用性アプライアンスに root ユーザーとしてログインします。
- /media/updates のマウント・ポイントに存在するファイルが重複しているかどうか判別するには、次のように入力します:
mount | grep media
- 複数のマウント・ポイントが「 (deleted) on /media/updates 」とコメントされているかどうか判別するため、出力結果を確認してください。
例えば、 /media/updates に複数のマウントを表示する場合があります:
[root@qradar-example.lab]# mount | grep media
/storetmp/732_QRadar_interimfix-7.3.2.20190522204210-IF02-20190710135412.sfs (deleted) on /media/updates type squashfs (ro,relatime)
/storetmp/732_QRadar_interimfix-7.3.2.20190522204210-IF02-20190710135412.sfs (deleted) on /media/updates type squashfs (ro,relatime)
Resolving The Problem
この事象を解決するには、QRadar 内の削除されたマウント・ポイントを除去するため、 unmount コマンドを使用する必要があります。
- 削除されたマウントを除去するには、次のように入力します:
umount /media/updates
注: QRadar デプロイメントでソフトウェアを更新中の場合、サーバーからファイルをアンマウントするために all_servers.sh を使用しないでください。 - [任意] QRadar コンソールを使用して、すべての QRadar アプライアンスおよびセカンダリ・アプライアンスからファイルをアンマウントするには、次のように入力します:
/opt/qradar/support/all_servers.sh -C -k "umount /media/updates"
- 削除されたボリュームが除去されたことを確認するには、次のように入力します:
mount | grep media
- 複数のマウント・ポイントが引き続き (deleted) で表示されている場合は、上記ステップ 1 を繰り返し実施してください。
結果
削除されたすべてのマウントがプライマリ・アプライアンスおよびセカンダリ・アプライアンスから除去された後、管理者はソフトウェア更新作業を続行するために SFS または ISO をマウントし、/installer を実行できます。QRadar ソフトウェアのバージョンとリリース・ノートのリストについては、https://ibm.biz/qradarsoftware のリンクをご参照ください。
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"Component":"High Availability","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All versions","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]
Was this topic helpful?
Document Information
Modified date:
31 May 2021
UID
ibm16378262