Troubleshooting
Problem
Unable to see or select any images within Cognos Analytics even after WebDAV has been enabled via https://www.ibm.com/support/pages/configuring-webdav-view-and-browse-images-ibm-cognos-analytics
Symptom
Error displayed -- 'There were no images or folders returned for this request. This might be because webdav is not enabled for this location. '
Cause
Directory Browsing has not been enabled on IIS web site.
Diagnosing The Problem
If receiving 'There were no images or folders returned for this request. This might be because webdav is not enabled for this location. ' and webdav has been set up according to - https://www.ibm.com/support/pages/configuring-webdav-view-and-browse-images-ibm-cognos-analytics
Try to access the location where the images are located (default - bi\samples\images) in a web browser like so --
http(s)://hostname/alias/bi/samples/images
A directory of all files listed in that location should be displayed. However, if a 403 error is displayed, that indicates that Directory Browsing has not been enabled on the IIS website.
Another method to confirm if the issue is related to Directory Browsing --
1. Reproduce the issue (add an image or navigate to image location in browser) and then navigate to IIS logs (default location - %SystemDrive%\inetpub\logs\LogFiles).
2. Open the log file corresponding with the date the issue was reproduced
3. A 403 14 status code at the time of testing will be shown.
Resolving The Problem
Enable the Directory Browsing feature in IIS (recommended)
To resolve this problem, follow these steps:
- Start IIS Manager. To do this, select Start, select Run, type inetmgr.exe, and then select OK.
- In IIS Manager, expand server name, expand Web sites, and then select the website that you want to change.
- In the Features view, double-click Directory Browsing.
- In the Actions pane, select Enable.
Document Location
Worldwide
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Document Information
Modified date:
02 December 2020
UID
ibm16376546