IBM Support

User name in the TM1 security on Planning Analytics Cloud appears as Planning Analytics/<mail address>

Troubleshooting


Problem

On Planning Analytics Cloud, user name on TM1 Clients/Groups dialog appears as "Planning Analytics/<mail address>" instead of "Planning Analytics/<First name> <Last name>". How can I change user name?

Cause

If a user logs into a TM1 component (Architect/TM1Webeb/Perspectives) before permission is provided then the name will appear in the TM1 security as:
Planning Analytics/<First name> <Last name>
If after the inviting process completes, and the Administrator manually goes into Architect (for example) and manually adds the user to TM1 Security then the name appears as
Planning Analytics/<mail address>
First Name, Last Name and mail address are pulled from IBM id profile.

Resolving The Problem

User name could be changed by modifying }TM1_DefaultDisplayValue attributes of }ElementAttributes_}Client.cub.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
20 September 2021

UID

ibm16374828