IBM Support

Unable to uninstall Cognos Analytics. "The uninstall is unable to continue. Please make sure all product services have been stopped and applications have been closed." Error returned.

Troubleshooting


Problem

In an attempt to uninstall Cognos® Analytics, the process fails and returns an error and the application is not removed from the system.

Symptom

Initiating the uninstaller for Cognos® Analytics is unsuccessful and the error "The uninstall is unable to continue. Please make sure all product services have been stopped and applications have been closed. Background process might take some time to stop. Please try again later." is returned. Additionally, checking the installation folder, all files remain. The Cognos® Analytics service is still present in the list of services on the system as well.

Cause

Files in the installation path are causing a lock that is preventing Cognos® Analytics from being uninstalled. The files in this scenario are:
  • <C11_install>/configuration/config_reg.xml
  • <C11_install>/configuration/config_reg.tmp

Environment

Cognos® Analytics installed on Windows® Server.

Diagnosing The Problem

The following troubleshooting steps do not resolve the issue:
  • All Cognos® Analytics services are stopped and there are no lingering processes.
  • Task Manager and the MMC Snap-in pane are closed.
  • Uninstallation is being run with Administrator privileges.
  • <C11_install>/configuration/cogstartup.lock file removed.
To confirm this particular scenario, check the following:
  • In <C11_install>/uninstall/logs - look for a log from the timestamp of the last unsuccessful uninstall attempt and look for an ERROR entry identifying config_reg.xml
  • In <C11_install>/configuration - look for config_reg.xml and config_reg.tmp. NOTE: config_reg.txt is expected to be present. Do not move or modify it.

Resolving The Problem

  • Remove <C11_install>/configuration/config_reg.xml and config_reg.tmp to a backup location on the system.
  • Make sure all explorer, Task Manager, and MMC windows are closed and reattempt to uninstall Cognos Analytics.
  • Run the uninstall from the command prompt with Administrator permissions (right click + run as Administrator) as follows:<C11_install>/uninstall/Uninstall_IBM_Cognos_Analytics.exe -i silent.
  • No message is returned on the command prompt. Wait a couple of minutes for the uninstall to complete.
  • In a couple of minutes check the installation path to confirm that the files and folders are gone. The <C11_install>/uninstall/logs path remains.
  • When the product is successfully uninstalled, the config_reg.tmp and config_reg.xml files that you removed to a backup location can be deleted.

Document Location

Worldwide

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Document Information

Modified date:
01 December 2020

UID

ibm16374056