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Planning Analytics For Excel: the "IBM Framework for Office" COM add-in is disabled each time Excel restarts - Or other abnormal behaviours on some client machines only

Troubleshooting


Problem

Each time Excel is restarted, Planning Analytics For Excel is deactivated.
It is always necessary to go to File / Options / Add-ins, go to manage the "COM add-ins" and check the "IBM Framework for Office" option again.
Even a simple uninstallation of Planning Analytics For Excel followed by a reinstallation does not solve the problem.
(This document can also be applied when encountering other abnormal behaviours, not related to data, that occurs only for some particular users or client machines)

Cause

Unknown issue caused by Excel behaviour.

Resolving The Problem

If Excel version is Excel 2016, go to File / Options, in "General", in "User Interface Options" section, select "Optimize for compatibility" if this option exists. If the problem is still not solved after reselecting the add-in and restarting Excel, then pursue...

Open Excel, and temporarily change the following security settings as a test:

1- Go to "File" / "Options"

2- Click "Trust Center" menu

3- Click "Trust Center Settings..." button

4- Select "Trusted Locations" menu and add the path to the CognosOfficeShim12.dll add-in (<install_path>\ibm\cognos\IBM for Microsoft Office)

5- Select "Add-ins" menu, near "Manage:", for both "Excel Add-ins" and then "COM add-ins", click the "Go" button,  and unselect all add-ins that are not related to Planning Analytics For Excel

6- Select "ActiveX Settings" menu and select the last option "Enable all controls without restrictions and without prompting..." and unselect "Safe mode..." option

7- Select "Macro Settings" menu, select "Enable all macros..." and check "Trust access to the VBA project object model"

8- Select "File Block Settings" and verify that Open option is unchecked for "Excel Add-in Files"

9- Validate, and restart Excel

10- Now, in File / Options / Add-ins,  near "Manage:", select "COM add-ins" in the list, and click the "Go" button,

11- Select the "IBM Framework for Office" and click the "Remove" button so that to make it disappearing from the list.

12- Validate, and close Excel again

13- Now  uninstall Planning Analytics For Excel from the Windows start menu

14- After uninstallation, open Excel again so that it may finish cleaning up things.

15- Close Excel again

16- Delete all temporary Excel files and subfolders inside this folder (except XLSTART if it exists): C:\Users\<User_Name>\AppData\Roaming\Microsoft\Excel\

17- Reinstall Planning Analytics For Excel

18- Reopen Excel and verify the add-in is now active.

      
       If this works after all these modifications, then change the Excel security settings back to what they were, one by one, until the right minimum necessary settings can be determined.

 

Document Location

Worldwide

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Product Synonym

PAX PAFE

Document Information

Modified date:
26 November 2020

UID

ibm16372984