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Capture network traffic from the browser's developer tools

Troubleshooting


Problem

This technote explains how to save network traffic in web development tools from the browser and save the .HAR file for analysis.

Cause

This technote can be used when troubleshooting an issue related to the webserver or browser.

Environment

  • Internet Explorer / Edge browser
  • Google Chrome browser
  • Mozila FireFox browser

Resolving The Problem

Google Chrome:

  1. Open developer tools (Menu > More tools > Developer tools or Ctrl + Shift + I or F12)
  2. Select the Network tab.
  3. Make sure that "Preserve log" is checked so that all traffic is captured.
  4. Access or refresh the page traffic needs to be captured for or a problem should be reproduced in
  5. Perform the steps to cause the behavior/issue
  6. Click on the down arrow "Export HAR..." button or Right-click within the Network capture pane then choose 'Save as HAR with content' and save the .har capture locally.
  7. Click on the Console tab > right-click > Save As > Save on the .log file.

Firefox (41+) :

  1. Go to Menu > Web Developer > Network
  2. Reload the page you want to get the log for
  3. Perform the steps to cause the behavior/issue
  4. Right click > Save All as HAR
  5. Click on Console tab > Select All
  6. Right-Click > Copy Message, and paste it / save on a .txt file.

Internet Explorer and Edge:

  1. Open Developer Tools (F12)
  2. Go to the network tab and click on the green arrow to start the tool
  3. Refresh the page to capture the logs
  4. Perform the steps to cause the behavior/issue
  5. Click 'Export captured traffic' icon and choose XML or HAR format.
  6. Click on Console tab > right-click > Copy All, and paste it / save on a .txt file.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3yAAC","label":"Installation and Configuration"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]

Document Information

Modified date:
19 November 2020

UID

ibm16370689