IBM Support

Known issues with IBM Spectrum Protect Operations Center Version 8.1.11

Question & Answer


Question

What are the known issues with IBM Spectrum Protect™ Operations Center Version 8.1.11?

Answer

The following issues have been identified in version 8.1.11 of the Operations Center:

Log-in and general issues

Servers

Storage Rules

Available languages: Interface text updates and documentation changes for Operations Center V8.1.11 are available in English only. Interface text and documentation for other languages are at the V8.1.10 level.

Message: ANR3218E UPDATE ADMIN: Administrator IBM-OC-server_name is a managed object and cannot be updated

Symptom

The error message ANR3218E is displayed. This error might be displayed when you try to connect a spoke server to the hub server, or when you try to update passwords on spoke servers.

Cause

The Operations Center runs independently of enterprise configuration, and is unable to update user IDs that are managed by the configuration manager. An administrator ID that the Operations Center creates and maintains on spoke servers was unintentionally placed under the control of the configuration manager.

When you try to connect a spoke server to the hub, the Operations Center attempts to register the monitoring administrator ID, IBM-OC-server_name, on the new spoke server. This same monitoring administrator ID with the same password is registered on the hub server and on all spoke servers. Periodically, the Operations Center automatically updates the monitoring administrator ID password on the hub and spoke servers. You typically do not need to use or manage this password. If the password update was not successful, and the Operation Center detects that the passwords on one or more spokes are not current, it prompts you to have it attempt the password update again.

If the error message ANR321E is displayed when you try to connect a spoke server or update a spoke server's monitoring administrator ID password, it might be because the monitoring administrator ID was inadvertently placed under the configuration manager's control. You might unintentionally place the monitoring administrator ID under the control of the configuration manager when you issue the DEFINE PROFASSOCIATION command. If you use a wildcard character in the DEFINE PROFASSOCIATION command to identify which administrators are associated with the configuration profile, you might unintentionally match the monitoring administrator ID. For example, you might associate all administrator IDs with the configuration profile by specifying admins=* in the DEFINE PROFASSOCIATION command.

Solution

Do not specify admins=* in the DEFINE PROFASSOCIATION command when you associate administrator IDs with the configuration profile. Instead, list all administrator IDs, excluding the monitoring administrator ID, in the command. For example, admins=admin1,admin2,admin3,admin4. Make sure to update the list when administrator IDs are added to or removed from the hub server.

Tip: You can use an enterprise configuration to maintain the monitoring administrator ID on spoke servers, but only if you designate the configuration manager server as the Operations Center hub server. For more information about grouping hub and spoke servers in an enterprise configuration, see
https://www.ibm.com/support/knowledgecenter/SSEQVQ_8.1.11/srv.install/c_oc_inst_reqs_tips_for_hub_spoke.html

Return to list

An object agent that is defined on a server is not shown in the Operations Center

Symptom

You defined an object agent on the server by using the DEFINE SERVER command, or you modified an object agent by using the UPDATE SERVER command. The command completes without errors, and you can verify that the object agent was defined by using the QUERY SERVER command. However, the object agent is not shown in the Operations Center. On the Object Agent page for the server, a message is displayed that says that an object agent must be configured before you can register an object client. If you try to register a client by using the Add Client wizard, you also get a message that says that no object agent is configured. If you try to define an object agent by using the Operations Center, the following error message is written to the activity log:


ANR4610E Command: An object agent server is already defined.

Cause

When you define an object agent by using the Operations Center, the Operations Center defines an endpoint to which object clients can send S3 requests. This endpoint is formed by using the IP address of the server and a port number. In the Operations Center, you can configure only the port number. The IP address is automatically determined to be the same as the server's IP address. When the object agent was created or modified by using the DEFINE SERVER or UPDATE SERVER command, a high-level address was specified that does not match the IP address of the server. For this reason, the Operations Center incorrectly determines that no object client is defined on the server.

Solution

Use the UPDATE SERVER command to update the object agent. By using the HLAddress parameter of the command, specify the IP address of the IBM Spectrum Protect server.

Return to list

Storage rule summary pages do not show recent data in the two-week history chart or the Recent History area

Symptom

To view the performance history of a storage rule, you select the storage rule on the Storage Rules page, and click Details. From the storage rule's details notebook, you go to the summary page for the storage rule, for a subrule, or for a source pool. The two-week history chart is empty or is missing the most-recent data. The Recent History area of the page is also missing data.

Cause

The CHECKFORTIERSTATS server option is set to No. In some situations, background processes for identifying eligible file spaces to be copied can degrade the performance of a storage rule. As a workaround to improve performance, the CHECKFORTIERSTATS server option was set to No. A side effect of that workaround is that the Operations Center cannot populate storage-rule summary pages with recent history. The information that is normally collected in the background to populate the two-week history chart and the Recent History area is not collected while the CHECKFORTIERSTATS server option is set to No.

Solution

Use the QUERY OPTION command to display the current setting of the CHECKFORTIERSTATS server option. From the command line, issue the following command:


q opt checkfortierstats

If the CHECKFORTIERSTATS server option is set to No, you can resolve this problem by setting the server option to Yes. If you set the CHECKFORTIERSTATS server option to Yes, the recent history is not immediately restored, but begins to be collected again the next time the storage rule runs. If the server option was previously set to No to resolve a performance problem, understand that setting it to Yes might degrade storage rule performance. You might need to choose between improved performance or displaying the two-week historical data.

To set the CHECKFORTIERSTATS server option, issue the following command:


setopt checkfortierstats yes

Return to list

[{"Line of Business":{"code":"LOB26","label":"Storage"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"ARM Category":[{"code":"a8m0z000000GpK2AAK","label":"Server->Troubleshooting"}],"ARM Case Number":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.1.11"}]

Document Information

Modified date:
19 November 2020

UID

ibm16365943