IBM Support

Single Sign-On (SSO) logout fails with the Firefox browser

Troubleshooting


Problem

The Single Sign-On (SSO) logout from IBM Content Navigator fails with the Firefox browser.

Symptom

Normally, when SSO is configured and the user clicks Log Out, the Log Out URL is sent, the Content Navigator desktop reloads, and then redirects to the SSO authentication page. With the Firefox browser, if the redirect to the SSO authentication page fails, the Content Navigator desktop reloads instead.

Cause

The SSO authentication cookie for logout is blocked by the Firefox browser. When this action  occurs, the SSO logout does not have all the required information to complete the logout, and the logout fails.

Resolving The Problem

To resolve the issue, in the Firefox browser

  1. Go to Options -> Privacy & Security -> Enhanced Tracking Protection.
  2. Set the level to Custom.
  3. Set the Cookies to Cross-site and social media trackers, or clear the Cookies.

The other settings in this section, such as, Tracking content, Cryptominers, and Fingerprinters are not related to this issue.

Document Location

Worldwide

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Document Information

Modified date:
13 December 2020

UID

ibm16365787