Troubleshooting
Problem
iBase 9.x Search 360 indexing . when indexing pdf content, cannot find/use the windows search default pdf filter (Reader Search Handler); that comes with the Windows operating system.
This article is for existing iBase 8.9.11/12/13 installations where Search 360 and the Adobe iFilter were in use for Search 360 indexing of pdf content.
Previously:
iBase 8.9.11/12/13 versions all needed a 3rd Party pdf iFilter and/or reader to be installed to allow Search360 to index pdf content. The recommended iFilter was Adobe 9 (please see https://www.ibm.com/support/pages/node/262623)
Now:
The Windows operating system now comes with a default pdf filter (Reader Search Handler) for windows search.
iBase 9 Search 360 indexing of pdf content, makes use of the default pdf filter (Reader Search Handler) for windows search.
On a system that has never had the Adobe ifilter or reader (versions 9 through to 11.03) installed; iBase 9.x Search360 will index pdfs 'out of the box'.
The Adobe IFilter/reader install has changed the windows registry , preventing iBase 9.x from using the windows default pdf filter.
Uninstalling the adobe iFilter/reader does not facilitate the restoration and working of the windows search default pdf filter (Reader Search Handler)
Symptom
Search360 indexing of pdf content fails to index the pdf document content.
The Search360 job history reports the following for each document with pdf content:
Error Message: “Error: Processing document field ‘Document_:Document_Content’ {RecordId: DOC1} Description: Unable to load filter for file with type .pdf. Return code E_FAIL"
Cause
iBase 9 cannot use the Adobe ifilter and the Adobe IFilter/reader install has changed the windows registry , preventing iBase from using the windows default pdf filter.
Installing the Adobe iFilter (for use with previous versions of iBase 8.9.x) made these changes :
1.) it sets the default pdf ifilter to PDF Filter:
(In the windows Operating system, select settings, indexing options, advanced options, file types and search for .pdf)
2.) It updates the registry
With this registry: HKEY_CLASSES_ROOT\.pdf\PersistentHandler
Environment
A clean Windows Operating system that has never had Adobe 9 - 11.0.3 ifilter/reader installed , has the windows native pdf filter set by default at windows O/S level.
This can be confirmed by going to settings, indexing options, advanced options, file types and search for .pdf
The above shows the Reader Search Handler filter.
It has this corresponding pdf PesistentHandler registry setting.
HKEY_CLASSES_ROOT\.pdf\PersistentHandler
Diagnosing The Problem
For the windows Server, operating system where S360 is installed:
1.) Check for this registry: HKEY_CLASSES_ROOT\.pdf\PersistentHandler and confirm it is set to
Resolving The Problem
Always back up the registry before making any changes
1.) Uninstall the Adobe IFilter
2.) remove the Adobe filter entry C:\Program Files\Adobe\Adobe PDF iFilter 9 for 64-bit platforms\bin\
from the system PATH environment variable.
2.) remove the Adobe filter entry C:\Program Files\Adobe\Adobe PDF iFilter 9 for 64-bit platforms\bin\
from the system PATH environment variable.
Uninstalling the Adobe 9 iFilter, changes the registry to
Uninstalling the Adobe ifilter 9 (or adobe Reader, versions up to 11.0.4), does not put the registry back to how it was before the iFilter (or adobe reader) was installed
Uninstalling the Adobe ifilter removes the PersistentHandler entry
it is important that you uninstall the adobe iFilter BEFORE you make the necessary changes to the registry
Uninstalling the adobe ifilter after you have made the registry changes will remove the PresistentHandler key and the changes you are about to make
3.) Edit the registry
Go to HKEY_CLASSES_ROOT\.pdf\PersistentHandler. Create the key if it does not exist.
If it does exist then that indicates you have not uninstalled the adobe iFilter yet and you should exit the registry editor now and uninstall the Adobe iFilter, then come back to using the registry editor!
Set the data value to {1AA9BF05-9A97-48c1-BA28-D9DCE795E93C}.
(include the curly brackets)
Exit the registry editor
Go to Task Manager > More details, Services.
Select WSearch. Right mouse-click, and then choose Restart.
Checking the Settings, indexing options, advanced settings for .pdf should show the default (Reader Search Handler) filter in place:
You may find you need to reboot the system.
You may find you need to set the 'open with' default app for pdfs back to Microsoft Edge
You may find you need to set the 'open with' default app for pdfs back to Microsoft Edge
You are now ready to upgrade iBase 8.9.13 to iBase 9.0.0 and Search360 indexing for pdfs will work using the native pdf filter
The upgrade involves removing iBase 8.9.13 and installing iBase 9.0.0, thern opening the database in iBase 9 designer.
Document Location
Worldwide
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Historical Number
TS004398152
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Document Information
Modified date:
03 November 2020
UID
ibm16359085