IBM Support

Applications do not recognize configuration changes

Troubleshooting


Problem

Maximo Application Suite configuration parameters can be updated from the Suite administration page by clicking Configuration and selecting and editing an item such as MongoDB.
Already deployed and activated applications are not updated with the new configuration settings, but keep using the previous settings.

Symptom

Updated configuration parameters are not used by deployed and activated applications. 

Cause

Applications do not dynamically refresh with updated configuration parameters. In deployment phase, these parameter are used in containers creation. 

Resolving The Problem

To update configuration parameters that are used by a deployed and activated you must undeploy and then redeploy and reactivate the application to pick up the new parameter values.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m0z000000cwZDAAY","label":"Maximo Application Suite"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.2.0"}]

Document Information

Modified date:
02 November 2020

UID

ibm16353379