Troubleshooting
Problem
We are getting the errors below while trying to save reports to the file system in Cognos Analytics. We have two dispatcher servers in this environment. This happens intermittently. We have full access to the path where it says ‘Access Denied’.
60 % of the time reports run successfully and save the output to the file system. 40% of the time we get the errors below.
CNC-DS-0025 Cannot write the report output to the file system: \\AAAAAA\BBB\Reports\Saved_Reports....(Access is denied). RSV-DST-0014 Unable to deliver the output of the report.
Cause
For dispatcher 1, the account logged in for the Cognos service is the domain service account, but for Dispatcher 2, it has 'Local System' as the account.
Resolving The Problem
Change the dispatcher 2 Cognos service to use the same domain account that is being used for the dispatcher 1 service. Also "manual" startup for the service is best. "Automatic" can cause issues because after a reboot of the server, there may be resource contention causing it to fail to start.
Ensure that the the user starting the Cognos service has full permissions on the Share. Also ensure that the share is in the same domain as the Cognos server.
For more detailed information about saving reports to a file location review this technote.
How to Save Report Outputs to a File Location on a Per Report Basis:
https://www.ibm.com/support/pages/how-save-report-outputs-file-location-report-basis
Document Location
Worldwide
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Document Information
Modified date:
22 October 2020
UID
ibm16351439