IBM Support

DOORS client context menu does not display OSLC link creation options

Troubleshooting


Problem

DOORS client context menu does not display OSLC link creation options

Symptom

After you set up OSLC integration between DOORS and IBM Engineering Workflow Management (EWM, formerly RTC), DOORS client is not able to display OSLC link creation menu.
There is no option to create OSLC links of the following types: Affected by, Implemented by, and Tracked by.
image 6749
However, DOORS Web Access is able to display OSLC link creation menu options.
The following 3 link types are displayed: Affected by, Implemented by, and Tracked by.
image 6748
The issue can be reproduced in the following environments:
Environment 1:
DOORS database server 9.7.2
DOORS Web Access 9.7.2
DOORS client 9.7.1
Environment 2:
DOORS database server 9.7.1
DOORS Web Access 9.7.1
DOORS client 9.7.1
This issue cannot be reproduced in the following environments:
Environment 1:
DOORS database server 9.7.2
DOORS Web Access 9.7.2
DOORS client 9.7.2
Environment 2:
DOORS database server 9.7.1
DOORS Web Access 9.7.1
DOORS client 9.7.2

Cause

There is a problem with DOORS client version 9.7.1 (and other earlier versions).

Environment

DOORS database server 9.7.1
DOORS Web Access 9.7.1
DOORS client 9.7.1

Resolving The Problem

Use DOORS client 9.7.2.
Note: DOORS client 9.7.2 can be used with DOORS database server 9.7.1 and DOORS Web Access 9.7.1.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"ARM Category":[{"code":"a8m50000000CipXAAS","label":"DOORS->OSLC"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
27 October 2020

UID

ibm16350053