IBM Support

AppHost Applications fail to Run and Pods show as Evicted

Troubleshooting


Problem

After installing IBM Resilient AppHost and successfully deploying applications,  the AppHost status shows as offline. When checking the status of the pod by running sudo kubectl get pods -A, the status of the pods shows that they are Evicted.

Symptom

Checking the status of the pod by running sudo kubectl get pods -A, the status show that the pods have been Evicted.
image 6660

Cause

The status Evicted is displayed when the system failed due to a resources issue, either low disc space or memory.

Environment

IBM Resilient AppHost

Diagnosing The Problem

Running the commands to describe the pods can provide information about the errors which caused the failure:
kubectl describe pod/<name space> -n <name>
example:

sudo kubectl describe pod/coredns-76b7cd546-vr47s-m7pc5 -n kube-system

In addition check the disc space and memory on the server to ensure that there is not a resource issue:

df -h

Also check to see what memory usage is:

top

image 6661

Resolving The Problem

Increase the resources available to allow Kubernetes (k3s) to start and AppHost to work properly again.
Restart the Kubernetes and the AppHost;
  • sudo systemctl restart k3s
  • sudo restartAppHost
If necessary, back up the config settings and redeploy your Applications again.

Document Location

Worldwide

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Document Information

Modified date:
19 April 2021

UID

ibm16348646