IBM Support

Why am I am unable to upgrade my WebSphere Application Server fixpack using Install Manager successfully? It fails with com.ibm.was.detect.corruption.

Question & Answer


Question

When upgrading to fixpack 8.5.5.18 (this problem might show up for any fixpack) it fails with following error:

Failed to load bundle com.ibm.was.detect.corruption. An issue has occurred with the package that cannot be resolved by Installation Manager. Contact IBM Support.

Cause

Install Manager version is old and there are some known issues with it.

Answer

My first recommendation is to upgrade IIM, as you are running a very old version of Installation Manager:

For example: IBM® Installation Manager Version 1.6.2 (1.6.2000.20130301_2248)

Upgrade IM to the latest level:

Here is the link to download the latest Installation manager: 1.9.1.3

https://www.ibm.com/support/pages/installation-manager-1913

Here is the link to follow to upgrade the current Installation manager to the latest version.

Using the migration wizard:

https://www.ibm.com/support/knowledgecenter/SSDV2W_1.8.5/com.ibm.cic.agent.ui.doc/topics/t_install_updates_im.html

Using command line mode:

https://www.ibm.com/support/knowledgecenter/SSDV2W_1.8.5/com.ibm.cic.commandline.doc/topics/t_imcl_update_im.html

2. If the problem persists, after successfully updating IBM IM to the 1.9.1.3 level, please collect the Installation Manager Agent data, and open a case with IBM Support for further trouble-shooting.

[{"Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"ARM Category":[{"code":"a8m50000000CdXCAA0","label":"Install Update or Migration->Traditional WAS->Fixpack Issues"}],"ARM Case Number":"TS004294845","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
08 October 2020

UID

ibm16346563