IBM Support

CM-CFG-5137 Content Manager was unable to complete the initialization of the content store

Troubleshooting


Problem

When starting Content Manager in a new installation of IBM Cognos Analytics 11.1.7 using a new Content Store database the following message is shown in Cognos Configuration tool:
CM-CFG-5063 A Content Manager configuration error was detected while connecting to the content store. CM-CFG-5063 A Content Manager configuration error was detected while connecting to the content store. Cause: CM-CFG-5137 Content Manager was unable to complete the initialization of the content store. For more information, review the log file. Before you restart Content Manager, you may need to recreate the content store database or clean it using dbClean_*.sql. Stack trace: CM-CFG-5137 Content Manager was unable to complete the initialization of the content store. For more information, review the log file. Before you restart Content Manager, you may need to recreate the content store database or clean it using dbClean_*.sql
Cleaning the database using dbClean_*.sql and starting Cognos again fails with the same message.

Symptom

The following messages are shown twice each in Cognos Configuration and in cogaudtit.log logfile during the startup:
'LogService', 'StartService', 'SUCCESS'.
'LogService', 'StartService', 'Success'.
Investigation of what tables get created shows that each attempt to start Cognos leaves different sets of tables in the content store.

Cause

Customer exported configuration from Cognos Analytics 11.1.5 and used it as cogstartup.xml in the Cognos Analytics 11.1.7. In 11.1.5 IP addresses were used in all URLs. The IP addresses were changed to the IP address of the server where 11.1.7 is installed but the invisible hostname populated by the installation process was not changed.

Resolving The Problem

Exit from Cognos Configuration tool
Clean the content store database schema using the script dbClean_*.sql from configuration/schemas/content/<db type>. If the database is Oracle, purge Oracle's recyclebin.
Remove cogstartup.xml in the configuration folder of Cognos Analytics 11.1.7 installation
Start Cognos Configuration tool and let it create a new cogstartup.xml with default values
Save in Cognos Configuration tool
Open cogstartup.xml in the configuration folder
Locate the XML element <crn:parameter name="hostName"> and record the value
In Cognos Configuration tool change hostname in all URLs in Environment and hostname in Configuration Group to the value recored on the previous step
Configure other properties, Content Store connection properties in particular
Save the configuration
Start Cognos service

Document Location

Worldwide

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Document Information

Modified date:
30 September 2020

UID

ibm16339671