Troubleshooting
Problem
Administrator logs onto the Controller application server, and launches 'Controller Configuration'.
Inside section 'Report Server', administrator clicks the green 'tick' button (to check the connection to the Cognos Analytics report server). An error appears.
Symptom
The underlying connection was closed: An unexpected error occurred on a send
Cause
Both of the following are true:
- Cognos Analytics server has been configured to forbit network connections via TLS 1.0 or 1.1
- In other words, it will only allow TLS 1.2
- Controller Application server has not been fully configured to use TLS 1.2.
Example:
In one real-life example, the customer had forgotten to "Enable TLS for .NetFramework" on the Controller application server.
Resolving The Problem
Reconfigure ALL your Controller components to use TLS 1.2.
- TIP: For full details, see separate IBM Technote #883036.
Example:
In one real-life example, the solution was to "Enable TLS for .NetFramework" on the Controller application server, by performing the following steps:
1. Open the registry editor, by clicking on ‘Start’ menu and typing: REGEDIT
2. Navigate to the following path: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
3. Right-click on v4.0.30319 and select New –> DWORD (32-bit)
2. Navigate to the following path: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
3. Right-click on v4.0.30319 and select New –> DWORD (32-bit)
- Set the name to: SchUseStrongCrypto
- Set the value to: 00000001
Related Information
Document Location
Worldwide
[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m0z000000brYKAAY","label":"Installation"}],"ARM Case Number":"TS004180950","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
Was this topic helpful?
Document Information
Modified date:
16 September 2020
UID
ibm16333469