Troubleshooting
Problem
Symptom
Cause
It is strongly recommended to read this document entirely before taking any actions to determine which scenario may be best applicable to your situation.
Environment
Diagnosing The Problem
To determine if there is a good system dump, login as padmin and run:
$ oem_setup_env
# sysdumpdev -L
0453-039
Device name: /dev/lg_dumplv
Major device number: 10
Minor device number: 11
Size: 21010432 bytes
Date/Time: Tue Feb 12 13:05:33 CST 2015
Dump status: 0 <-----
dump completed successfully <-----
-0 Successful system dump
-2 Dump device is too small (partial dump may be available)
-3 Dump facility has failed (dump crashed or did not start)
-4 Dump failed due to i/o error (bad disk or disk adapter)
Resolving The Problem
If the VIOS has no network connectivity, but it is accessible via console, this indicates the partition is not in a hung condition, and it is possible that the issue could be a network-related problem. Networking is beyond the scope of this document. For assistance troubleshooting VIOS/AIX networking issues, please, contact your network administrator to see if they can justify the network outage. If no issues are identified by your network administrator that could justify the loss of network connectivity to the VIOS, contact your local IBM SupportLine Representative and request to speak to the networking team for investigation.
If the VIOS partition is determined to be hung (no network connectivity and no console access) as previously noted, and root cause analysis is needed, a system memory dump must be forced while the partition is in the hung state.
IMPORTANT
- Forcing a OS system dump on the VIOS partition will cause the VIOS to be rebooted. Therefore, ensure all client partitions that are served by that VIOS are fully redundant for network and disk IO through a second VIOS before initiating the OS system dump.
- This does not apply to a VIOS partition that is part of an SSP cluster environment. If the hung VIOS is part of an SSP cluster, contact your local IBM SupportLine Representative to discuss. Do NOT force a dump.
To force a system dump on the VIOS, refer to the following technote:
> Section LPAR using HMC > HMC GUI
After forcing the system memory dump, check that the VIOS partition boots up to the padmin login prompt, and verify 'sysdumpdev -L' output reports the dump completed successfully. If there is a good dump (Dump status: 0), proceed to capture VIOS snap data. Then contact you local IBM SupportLine Representative to have the dump analyzed.
VIOS Crashed or Hung and there is no successful dump
In some cases, there may be a partial dump (dump status: -2) or a minidump that might allow for an educated speculation. If a minidump was captured, it will be reflected in the error log. To review the error log, login as padmin and run:
$ errlog
Related Information
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Modified date:
07 May 2024
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