Troubleshooting
Problem
User launches Controller Web. An error appears.
Symptom
Server is not reachable or still initializing, please refresh the page in a few seconds
Cause
There are several known causes for the 'Server is not reachable or still initializing, please refresh the page in a few seconds' error.
- TIP: See separate IBM Technote #0791129 for more examples.
This Technote specifically relates to the scenario where the cause is that the configuration file 'config.js' was corrupt/invalid.
Diagnosing The Problem
In this specific scenario, look in the Event Viewer for entries similar to:
Faulting application name: prunsrv.exe, version: 1.0.15.0, time stamp: 0x51543b9d
Faulting module name: ntdll.dll, version: 10.0.17763.1192, time stamp: 0x5854f5da
Exception code: 0xc0000005
Fault offset: 0x00000000000124b1
Faulting process id: 0x3330
Faulting application start time: 0x01d66b345ae46880
Faulting application path: C:\Program Files\ibm\cognos\ccr_64\frontend\prunsrv.exe
Faulting module path: C:\windows\SYSTEM32\ntdll.dll
Report Id: 58c2d3f3-dfba-42c6-aef4-4e5bba4de8a3
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Also, inside Task Manager you will NOT see any 'javaw.exe' processes (although you may see some 'java.exe' processes)
- In other words, it will NOT look similar to this 'good' server example:
Also there are no 'prunsrv.exe' processes.
- In other words, it will NOT look similar to this 'good' server example:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Also, try Telnet to connect to the backend port (by default 3000), by running this command (on the Controller application server): TELNET localhost 3000
- Faulty server:
- Good server:
The command prompt screen will change to entirely black (indicating that telnet has connected to a service on TCP port 3000):
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
TIP: By default, Telnet is not installed on Windows. The easiest way to install it is via a command prompt, for example for Windows 2019:
dism /online /Enable-Feature /FeatureName:TelnetClient
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Resolving The Problem
Fix the mistake/corruption inside the configuration file 'config.js'.
Example:
In one real-life example, the solution was:
1. Browse to here: C:\Program Files\ibm\cognos\ccr_64\frontend
2. Rename the existing file "config.js"
- For example, change its name to: config-js.BAD
3. Obtain a fresh (uncorrupted) copy of "config.js" and copy it to: C:\Program Files\ibm\cognos\ccr_64\frontend
- For example copy it from an existing 'good' application server
- Alternatively, perform a default installation of Controller server on a 'test' PC, and copy the file from there.
4. Edit the file "config.js" and modify its settings to work with the new application server
- For example modify values such as the servername
- TIP: For more details, see separate IBM Technote #791535
5. Save changes, restart the Controller Web services, and test.
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m0z000000GnFaAAK","label":"Controller WEB"}],"ARM Case Number":"TS004026069","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.4.x","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
12 August 2020
UID
ibm16258223