IBM Support

Cognos is not starting using a CA certificate

Troubleshooting


Problem

Installed Control Center Monitor to use secure connections and with a CA Certificate to be used in Cognos as well.
The configCC ran without errors, but Cognos is not starting.

Symptom

Cognos does not start when Control Center is started.

Cause

Password being used for the certificate and keystore in CCM was 20 characters long.
This is not being handled by Cognos the encrypted password in cogstartup.xml was not correct.
CAMKeystore did have the correct password, but cogstartup.xml is wrong.

Diagnosing The Problem

in /Cognos/logs look at cbs_isrunning_WebSphereLiberty.log and find the following

 FATAL t[46759880] CBSCryptoHelper CAM_CryptoInitialize failed, return code: -2113929210

FATAL t[46759880] CBSCryptoHelper CAM_CryptoInitialize failed, CAM error details: <errorDetail><errorCode>-2113929065</errorCode><errorMessage>CAM-CRP-0321 The GSKit function 'gsk_environment_init' failed with the error code '408'.

Resolving The Problem

Use a password length of no longer than 14 for the Control Center keystore and certificate.
Once you have changed the keystore and certificate password run configCC to input the new password for the keystore and go all the way through to the end so Cognos is updated with the new password.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9GLA","label":"IBM Control Center"},"ARM Category":[{"code":"a8m0z000000cwW9AAI","label":"REPORTING\/COGNOS"}],"ARM Case Number":"TS003906084","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.1.2;6.1.3","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
10 August 2020

UID

ibm16257573