Troubleshooting
Problem
User launches Controller. User receives error message.
Symptom
Invalid Database Version.
This version of Controller requires database version: 882
TIP: The database version will vary, depending on which version of Controller is installed on the application server.
Cause
There are several different potential causes:
- Scenario #1 - The version of the Controller client (installed on the client device) does not match the version of the Controller server (installed on the Controller application server).
- Scenario #2 - The Controller application repository database's schema version does not match the version that the Controller client is compatible with.
- Scenario #3 - (RARE) The database table XFRANGO is (temporarily) locked/unavailable, caused by the database server being (temporarily) overloaded.
- For more information, see separate IBM Technote #1998287.
Environment
More Information on Scenario #2:
Different Controller versions have different 'DB Versions' associated with them.
For example:
- Controller 8.3 RTM <=> database (schema) version 710
- Controller 8.3 service pack 5 <=> 711
- Controller 8.4 RTM <=> 737
You cannot launch the Controller client if the database version ('schema version') does not match the version of the Controller application server software you are running.
- TIP: For a long list of Controller software version (and corresponding database/schema version) examples, see separate IBM Technote #1367448
Diagnosing The Problem
On the Controller application server, perform the following steps:
1. Launch 'Controller Configuration'
2. Open 'Database Connections'
3. Highlight the relevant connection
4. Click the green 'play' button ("Run"):
5. Ensure that (inside the 'UDL File' box) it is pointing to the correct database connection
6. Ensure that the setting 'Controller DB' is chosen
7. Click the button 'Connect'
8. Compare the number listed inside 'Current Version' with the number inside 'Upgrade to'.
Scenario #1
The version of the *database* is the same as the version of the application software:
In this case, the cause of the error is that the end user's client device has a different version of Controller from the version running on the Controller application server.
- TIP: For more information, see separate IBM Technote #1366341.
Scenario #2
Example #A - 'Current Version' < 'Upgrade to' version:
Resolving The Problem
Scenario #1 - 'Current Version' = 'Upgrade to' version
In this scenario, logon to the client device and:
- Uninstall the version of Controller client currently installed
- Then install the same version of Controller client that is running on the application server.
TIP: For more information, see separate IBM Technote #1366341.
Scenario #2
The solution depends on whether the 'current version' is smaller or larger than the 'upgrade to' version:
- TIP: This process is non-reversible. Once you have upgraded the database, you cannot use the database on a system which has a lower version of Controller software installed
- For more information, see IBM Technote #1346294.
Example #A - 'Current Version' < 'Upgrade to' version
For most customers, the best solution to this is to use the 'Database Conversion' utility, and click 'Upgrade' (to upgrade the database to the higher version):
[Alternatively you can downgrade the version of Controller software installed on the application server, to the same version which matches the database].
Example #B - 'Current Version' > 'Upgrade to' version
Upgrade the version of Controller software installed on the application server, to the same version which matches the database.
Scenario #3
See separate IBM Technote #1998287.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21383331