IBM Support

Can't connect to the LDAP server: CAM-AAA-0064 CAM-AAA-0026 CAM-AAA-0082

Troubleshooting


Problem

When trying to connect to an LDAP Directory Server using SSL, either by using the test functionality in Cognos Configuration or by starting IBM Cognos 11, an error message is logged and the connection fails

Symptom

CAM-AAA-0064 The function 'Configure' failed."
The user cannot access the application at this time."
CAM-AAA-0026 The function call to 'LDAPAPIWrapper_ldapssl_client_init' failed with error code: '-1'"
CAM-AAA-0082  Unable to initialize the SSL client because the certificate database is invalid."

Cause

When you use an LDAP namespace which is configured for LDAPS (LDAP via SSL) you have to
provide a proper Key Database containing the LDAP servers certificate. If this Key Database is
damaged, incomplete or inaccessible this error is thrown.
 

Resolving The Problem

  • Confirm that the Cognos service account has access to the certificate directory configured in the "SSL Certificate Directory" property path
  • Confirm that Cognos is connecting directly to the LDAP Server and not via a Load Balancer. Load Balancer architecture is not currently supported.
  • Confirm there are no typos in the "SSL Certificate Directory" property path


 

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Document Information

Modified date:
14 July 2020

UID

ibm16248329