Troubleshooting
Problem
A connection to Salesforce specifies a version of the Salesforce API to be used.
If the default version is changed, testing a connection will not return an error while importing metadata will fail.
If the default version is changed, testing a connection will not return an error while importing metadata will fail.
For example, Cognos Analytics defaults to version 45 of the Salesforce API. Changing the value from 45 to 47 or higher will cause failures.
Symptom
Attempting to import schems from a Salesforce connection fails throws MSR_GEN_0071 Internal error getting catalogs and schemas.
Cause
Changes to the version of the Salesforce API may require an updated Salesforce WSDL file.
The Salesforce WSDL file used by Cognos Analytics 11.1.7 is based on version 45 of the Salesforce API.
The newer Salesforce API version may not be compatible with the WSDL file, which causes internal failures.
The newer Salesforce API version may not be compatible with the WSDL file, which causes internal failures.
Resolving The Problem
Update the connection to use the Salesforce API version which Cognos Analytics would use in a new connection.
For example, the value 45 would be used in Cognos Analytics 11.1.7.
For example, the value 45 would be used in Cognos Analytics 11.1.7.
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6nAAC","label":"Installation and Configuration->Data Sources"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.1.7","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
16 July 2020
UID
ibm16246207